Skip to content

XAware Community

Get the Flash Player to see this player.
Flash Image Rotator Module by Joomlashack.
XAware 5.6
Need Help
Webinars and Events
Advanced Tutorials
Webinars and Events

You are here: Home arrow Forums
XAware Community Forums
Welcome, Guest
Please Login or Register.    Lost Password?
Go to bottom Post Reply Favoured: 0
TOPIC: Re:Salesforce BizComp Development
#3550
tferguson (User)
XAware expert
Posts: 494
User Offline Click here to see the profile of this user
Re:Salesforce BizComp Development 11 Years, 3 Months ago Karma: 6  
Hello Murat,

I am running the same BizDoc and bizcomp I sent you based on the XML you gave me. The interesting thing is that I get the following results:
<Document>
<UpsertResults>
<UpsertResult>
<Id>0017000000V2X6bAAF</Id>
<Errors>
<Errors>
<Error>
<Fields />
<Message>Duplicate id specified:0017000000V2X6bAAF</Message>
<StatusCode>
<StatusCode>
<Value>DUPLICATE_VALUE</Value>
</StatusCode>
</StatusCode>
</Error>
</Errors>
</Errors>
<Success>false</Success>
<Created>false</Created>
</UpsertResult>
<UpsertResult>
<Id>0017000000V2fKIAAZ</Id>
<Errors>
<Errors>
<Error>
<Fields />
<Message>Duplicate id specified:0017000000V2fKIAAZ</Message>
<StatusCode>
<StatusCode>
<Value>DUPLICATE_VALUE</Value>
</StatusCode>
</StatusCode>
</Error>
</Errors>
</Errors>
<Success>false</Success>
<Created>false</Created>
</UpsertResult>
<UpsertResult>
<Id>0017000000V2fKJAAZ</Id>
<Errors>
<Errors>
<Error>
<Fields />
<Message>Duplicate id specified:0017000000V2fKJAAZ</Message>
<StatusCode>
<StatusCode>
<Value>DUPLICATE_VALUE</Value>
</StatusCode>
</StatusCode>
</Error>
</Errors>
</Errors>
<Success>false</Success>
<Created>false</Created>
</UpsertResult>
<UpsertResult>
<Id>0017000000V2X6YAAV</Id>
<Errors>
<Errors>
<Error>
<Fields />
<Message>Duplicate id specified:0017000000V2X6YAAV</Message>
<StatusCode>
<StatusCode>
<Value>DUPLICATE_VALUE</Value>
</StatusCode>
</StatusCode>
</Error>
</Errors>
</Errors>
<Success>false</Success>
<Created>false</Created>
</UpsertResult>
<UpsertResult>
<Id>0017000000V2X6dAAF</Id>
<Errors>
<Errors>
<Error>
<Fields />
<Message>Duplicate id specified:0017000000V2X6dAAF</Message>
<StatusCode>
<StatusCode>
<Value>DUPLICATE_VALUE</Value>
</StatusCode>
</StatusCode>
</Error>
</Errors>
</Errors>
<Success>false</Success>
<Created>false</Created>
</UpsertResult>
<UpsertResult>
<Id>0017000000V2X6bAAF</Id>
<Errors>
<Errors>
<Error>
<Fields />
<Message>Duplicate id specified:0017000000V2X6bAAF</Message>
<StatusCode>
<StatusCode>
<Value>DUPLICATE_VALUE</Value>
</StatusCode>
</StatusCode>
</Error>
</Errors>
</Errors>
<Success>false</Success>
<Created>false</Created>
</UpsertResult>
<UpsertResult>
<Id>0017000000V2fKIAAZ</Id>
<Errors>
<Errors>
<Error>
<Fields />
<Message>Duplicate id specified:0017000000V2fKIAAZ</Message>
<StatusCode>
<StatusCode>
<Value>DUPLICATE_VALUE</Value>
</StatusCode>
</StatusCode>
</Error>
</Errors>
</Errors>
<Success>false</Success>
<Created>false</Created>
</UpsertResult>
<UpsertResult>
<Id>0017000000V2fKJAAZ</Id>
<Errors>
<Errors>
<Error>
<Fields />
<Message>Duplicate id specified:0017000000V2fKJAAZ</Message>
<StatusCode>
<StatusCode>
<Value>DUPLICATE_VALUE</Value>
</StatusCode>
</StatusCode>
</Error>
</Errors>
</Errors>
<Success>false</Success>
<Created>false</Created>
</UpsertResult>
<UpsertResult>
<Id>0017000000V2X6YAAV</Id>
<Errors>
<Errors>
<Error>
<Fields />
<Message>Duplicate id specified:0017000000V2X6YAAV</Message>
<StatusCode>
<StatusCode>
<Value>DUPLICATE_VALUE</Value>
</StatusCode>
</StatusCode>
</Error>
</Errors>
</Errors>
<Success>false</Success>
<Created>false</Created>
</UpsertResult>
<UpsertResult>
<Id>0017000000V2X6dAAF</Id>
<Errors>
<Errors>
<Error>
<Fields />
<Message>Duplicate id specified:0017000000V2X6dAAF</Message>
<StatusCode>
<StatusCode>
<Value>DUPLICATE_VALUE</Value>
</StatusCode>
</StatusCode>
</Error>
</Errors>
</Errors>
<Success>false</Success>
<Created>false</Created>
</UpsertResult>
</UpsertResults>
</Document>

The interesting thing is that I have upsert tests that work correctly, but they work on Contact objects which have the Email field defined as an idLookup field, so xa:key is defined as xa:key="Email", and it appears to work, I am now wondering if you cannot use Id on an upsert and you have to choose something else. I will continue to research this.

-Tim
 
Report to moderator   Logged Logged  
  The administrator has disabled public write access.
      Topics Author Date
    thread link
Salesforce BizComp Development
kvandersluis 2009/02/05 12:32
    thread link
thread linkthread link Re:Salesforce BizComp Development
kvandersluis 2009/02/05 12:33
    thread link
thread linkthread linkthread link Re:Salesforce BizComp Development
kvandersluis 2009/02/05 12:34
    thread link
thread linkthread linkthread linkthread link Re:Salesforce BizComp Development
kvandersluis 2009/02/05 12:35
    thread link
thread linkthread linkthread linkthread linkthread link Re:Salesforce BizComp Development
kvandersluis 2009/02/05 12:38
    thread link
thread linkthread linkthread linkthread linkthread linkthread link Re:Salesforce BizComp Development
tferguson 2009/02/05 15:49
    thread link
thread linkthread linkthread linkthread linkthread linkthread linkthread link Re:Salesforce BizComp Development
molmez 2009/02/06 09:26
    thread link
thread linkthread linkthread linkthread linkthread linkthread linkthread linkthread link Re:Salesforce BizComp Development
tferguson 2009/02/06 16:19
    thread link
thread linkthread linkthread linkthread linkthread linkthread linkthread linkthread linkthread link Re:Salesforce BizComp Development
tferguson 2009/02/06 16:48
    thread link
thread linkthread link Re:Salesforce BizComp Development
kvandersluis 2009/02/06 14:08
    thread link
thread linkthread link Re:Salesforce BizComp Development
molmez 2009/02/09 04:52
    thread link
thread linkthread linkthread link Re:Salesforce BizComp Development
tferguson 2009/02/09 10:15
    thread link
thread linkthread linkthread linkthread link Re:Salesforce BizComp Development
tferguson 2009/02/09 10:26
    thread link
thread linkthread linkthread linkthread linkthread link Re:Salesforce BizComp Development
molmez 2009/02/09 13:11
    thread link
thread linkthread linkthread linkthread linkthread linkthread link Re:Salesforce BizComp Development
dkokkeel 2009/02/09 15:04
    thread link
thread linkthread linkthread linkthread linkthread linkthread linkthread link Re:Salesforce BizComp Development
dkokkeel 2009/02/09 16:20
    thread link
thread linkthread linkthread linkthread linkthread linkthread linkthread linkthread link Re:Salesforce BizComp Development
kvandersluis 2009/02/11 19:39
    thread link
thread linkthread linkthread linkthread linkthread linkthread linkthread linkthread linkthread link Re:Salesforce BizComp Development
dkokkeel 2009/02/17 17:30
    thread link
thread linkthread linkthread linkthread linkthread linkthread linkthread linkthread linkthread linkthread link Re:Salesforce BizComp Development
kvandersluis 2009/02/17 19:27
    thread link
thread linkthread link Re:Salesforce BizComp Development
molmez 2009/02/09 04:53
    emo
thread linkthread link Re:Salesforce BizComp Development
molmez 2009/02/09 17:19
    thread link
thread linkthread link Re:Salesforce BizComp Development
molmez 2009/02/10 06:02
    thread link
thread linkthread linkthread link Re:Salesforce BizComp Development
tferguson 2009/02/10 11:05
Go to top Post Reply
Powered by FireBoardget the latest posts directly to your desktop

Community Login

Get the Flash Player to see this player.
Flash Image Rotator Module by Joomlashack.
Commercial
Free Training
QuickStart Packages
Image 4 Title
Image 5 Title

Visit XAware.com